Help Center

My JibJab Account →

What are the minimum system/browser requirements to use JibJab?

Here's a list of browsers/minimum versions we support.

Desktop:

  • Chrome 34+
    Edge 13+
    FireFox 48+
    Internet Explorer 10+
    Safari 8+ 

Mobile:

  • iOS 9+

The latest Adobe Flash Player is required for optimum video playback. You can download the most recent version here.

We do not support the AOL Browser.